Форум компании Ритм - НПО «Ритм»

перенос БД GeoRITM на внешний сервер

Поиск  Пользователи  Правила  Войти  
Страницы: 1
RSS
перенос БД GeoRITM на внешний сервер
Добрый день!
Хотел уточнить возможность переконфигурирования GEO.RITM на внешний сервер с БД бывает что docker geo-storage по неизвестным (вирусным, криворуким, багообразным) образом помирает .
Где и какие параметры необходимо откорректировать указать путь к новой БД
Не рекомендую использовать docker на Windows - не надёжно и трафик от приборов в 10 раз больше в таком случае.
В Applications сделайте DISABLE приложения, затем настройки подключения к БД смотрите в
Payara=>Resources=>JDBC=>JDBC Connection Pools
=>mysql_ritm_rootPool=>Additional Properties=>URL
=>mysql_oldritm_rootPool=>Additional Properties=>URL
=>mysql_idp_rootPool=>Additional Properties=>URL
=>mysql_georitm_data_rootPool=>Additional Properties=>URL
=>mysql_contact_rootPool=>Additional Properties=>URL
Для каждого подключения измените адрес БД.
Рисунок
Перенос БД на другой сервер прошел почти легко все получилось!
БД лежит на другом нормально доступном месте (прощай geo-storage), теперь есть возможность оперативно переключать GEO на резервный сервак с БДsmile:)
Сразу сделал обновление до 2.40
Но в IDP пришлось пересоздать все потоки, старые не запускаются выдают внутренняя ошибка и не удаляются.
Цитата
Pavel Sh пишет:
Перенос БД на другой сервер прошел почти легко все получилось!

Отлично!
Цитата
Pavel Sh пишет:
Но в IDP пришлось пересоздать все потоки, старые не запускаются выдают внутренняя ошибка и не удаляются.

Значит не верные настройки потоков.
Скорее всего причина в потоке с несуществующим COM. Точнее можно сказать по логам. См. http://ritm.ru/forum/?PAGE_NAME=messa...essage6975
и
http://ritm.ru/forum/?PAGE_NAME=messa...essage7098
Страницы: 1